We have moved to a Please visit there for updated posts

Tuesday, October 16, 2007

Drill Downs - Common mistakes made.

Problem statement:

  • We configure a drill down and we test it. It works fine and it takes us to the destination view that we have provided. Another user logs in for him the drill down disappear. It is just plain text field.

  • When we click on the drill down it gives us an error

    “You do not have permission to view this record or this record has been deleted”

  • Drill down is working for some users and some users are facing error while using that drill down.


The reason behind the problems mentioned above is Responsibilities. Yes, It is as simple as that.

We are going from one view to another view and if we don’t have that view in our responsibility we migh face one of the above mentioned errors. Some time more than one destination is provided, as is the case of the dynamic drill down and they are executed in the sequence that we provide. If views that have been mentioned in the sequence are not assigned to our responsibility then we can again face the above mentioned error.

Will try to add specific case studies explaining the above mentioned scenarios.


Anonymous said...

What about the "Create Response" button in Campaigns? I'm getting that error when clicking on that button. We are not getting it in PROD, but we are in DEV and QA with the same SRF.

Anonymous said...

Also when I compiled the Response BC to the PROD srf, the button no longer works. I sif back in original before modifying and error remains. Had to point to original srf for the button to work. So at that point it doesn't appear to be a responsibility issue. I even tried your suggestion by creating Siebel Admin 2 adding all views and assigning myself to it and the button still doesn't work.

You Might want to read following articles also.